Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

PLEASE NOTE: these instructions are for the install of tranSMART version 16.1; they will be updated when version 16.2 is releasedbeta release 19.0. They may not fully apply to earlier versions.

Overview

These notes describe the command line tools and features that are required for tranSMART version 1619.10. The suggestions given are based on Ubuntu 1418.04 but in most cases for other systems simple analogs are available. There is a set of scripts, on GItHub GitHub

, written for bash on Ubuntu 18.04, that verify these requirements; in particular, see the README.md and CheckAll.sh.

Table of Contents

...

git --version
make --version
java -version (version JDK 78)
ant -version
mvn --version
tar --version
rsync --version
php --version (57.42 or higher)
g++ --version
gfortran --version
R --version (3.6.1.2)
psql --version (9.26 or higher)
groovy --version (2.14.16 or higher)

The following files, directories, links should be present:

...

On the datasetExplorer page you should see a "tree" display on the left with a top level entry "Public Studies". Expanding this entry (click on the '+') should reveal a study 'GSE8581' .